加入收藏 | 设为首页 | 会员中心 | 我要投稿 拼字网 - 核心网 (https://www.hexinwang.cn/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDOJ 5832 a water problem(大数取模)

发布时间:2021-01-24 03:34:40 所属栏目:大数据 来源:网络整理
导读:Problem Description Two planets named Haha and Xixi in the universe and they were created with the universe beginning. There is? 73 ?days in Xixi a year and? 137 ?days in Haha a year.? Now you know the days? N ?after Big Bang,you need to a

Problem Description Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is? 73 ?days in Xixi a year and? 137 ?days in Haha a year.?

Now you know the days? N ?after Big Bang,you need to answer whether it is the first day in a year about the two planets. ?
Input There are several test cases(about? 5 ?huge test cases).

For each test,we have a line with an only integer? N(0≤N) ,the length of? N ?is up to? 10000000 . ?
Output For the i-th test case,output Case #i:,then output "YES" or "NO" for the answer. ?
Sample Input

  
  
   
   10001
0
333
  
  
?
Sample Output
  
  
   
   Case #1: YES
Case #2: YES
Case #3: NO
  
  
?
Author UESTC ?
Source 2016中国大学生程序设计竞赛 - 网络选拔赛? ?
Recommend wange2014

总结:打卡题,直接大数取模过

#include<iostream>
#include<string>
#include<cstdio>
int const maxn=10000000+10;
char str[maxn];
using namespace std;
int main(){
   //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int t=0;
    while(scanf("%s",str)!=EOF)
    {
        t++;
        int i;
        int rem=0;
        for(i=0;str[i];i++){
            rem=rem*10+str[i]-'0';
            rem=rem%10001;
        }
        printf("Case #%d: ",t);
        if(rem==0) printf("YESn");
        else printf("NOn");
    }
}

(编辑:拼字网 - 核心网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!