-
MySQL主从不同步的几种状况总结
所属栏目:[MySql教程] 日期:2022-04-07 来源:DaWei
MySQL主从不同步的几种情况总结: 1.网络的延迟 由于mysql主从复制是基于binlog的一种异步复制,通过网络传送binlog文件,理所当然网络延迟是主从不同步的绝大多数的原因,特别是跨机房的数据同步出现这种几率非常的大,所以做读写分离,注意从业务层进行前[详细]
-
linux一些基础命令与mysql索引
所属栏目:[MySql教程] 日期:2022-04-07 来源:DaWei
Linux的一些基本命令: 在Linux中大部分的操作都是通过终端来实现的,或者直接使用命令行界面,一般使用Linux架构服务器的话,安装的都是命令行界面,不安装图形化界面的原因是因为没有必要,并且对于服务器来说越稳定越好,如果使用图形化界面就容易出bug漏[详细]
-
mysql hash索引
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
今天研究下mysql中索引,首先我应该知道的是,mysql中不同存储引擎的索引工作方式不一样,并且不是所有的存储引擎都支持所有类型的索引。即使多个存储引擎支持同一种类型的索引,那么他们的实现原理也是不同的。不同的引擎对于索引有不同的支持:Innodb和MyI[详细]
-
MySQL入门--如何调用命令行命令
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
如何调用命令行命令( mysqlmysqldumpmysqladminmysqlimport ) mysql 是通用的命令行客户机,用于向服务器发送 SQL 语句,其中包括用于管理的 SQL 语句。 mysqladmin 是可帮助管理服务器的管理命令行客户机。 mysqlimport 为 LOAD DATA INFILE 语句提供[详细]
-
MySQL 8.0.2 新特性 UNDO表空间管理的灵活性提升
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
一篇自己翻译的文章,原文来自MySQL Server官方团队博客: 在MySQL 8.0.2 DMR版本中,我们将提高InnoDB的UNDO表空间易管理性。 〇 主要有几点提升: 1、可以随时自由地创建或删除UNDO表空间; 2、无论是否需要进行InnoDB恢复,也可以在启动前更改相关设置;[详细]
-
mysql 启动错误 InnoDB Operating system error number 13
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
service mysqld status 可以看mysqld状态 service mysqld start 可以启动mysql 出现启动错误可以查看/var/log/mysqld.log 如果错误信息如下 131124 00:00:43 mysqld started 131124 0:00:43 InnoDB: Operating system error number 13 in a file operation.[详细]
-
MySQL基础知识点汇总
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
MySQL基础知识点汇总: 1.什么是SQL语句 sql语言:结构化的查询语言。(Structured Query Language),是关系数据库管理系统的标准语言。 它是一种解释语言:写一句执行一句,不需要整体编译执行。 语法特点: 1.没有 ,字符串使用 包含 2.没有逻辑相等,赋[详细]
-
MySQL--索引优化原则
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
索引优化原则 1、最左前缀匹配原则,联合索引,mysql会从做向右匹配直到遇到范围查询(、、between、like)就停止匹配,比如a = 1 and b = 2 and c 3 and d = 4 如果建立(a,b,c,d)顺序的索引,d是用不到索引的,如果建立(a,b,d,c)的索引则都可以用到,a,b,d的[详细]
-
浅谈MySQL中优化sql语句查询常用的30种方法
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
浅谈MySQL中优化sql语句查询常用的30种方法: 1、 对查询进行优化,应尽量避免全表扫描,首先应考虑在 where 及 order by 涉及的列上建立索引。 2、 应尽量避免在 where 子句中使用!=或操作符,否则将引擎放弃使用索引而进行全表扫描。 3、 应尽量避免在 whe[详细]
-
Centos7安装mysql数据库
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
Centos7安装mysql 新地址 下载安装mysql 卸载自带的迷你库 rpm -qa | grep mariadb | xargs rpm -e --nodeps 下载yum镜像下载源 wget -i -c http://dev.mysql.com/get/mysql57-community-release-el7-10.noarch.rpm 安装yum下载源 yum -y install mysql57-co[详细]
-
MySQL null值字段是否使用索引的总结
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
null和not null索引失效与否主要与表中字段的设立有关系,分为相应的两种情况,当对不能是null的字段使用索引时,条件无论是null或者not null 索引都失效,当对能是null的字段使用索引时,条件无论是null或者not null 索引都生效. 以下是null字段走索引的一[详细]
-
semi-sync插件崩溃导致MySQL重启的故障分析全过程
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
导读 semi-sync插件崩溃导致MySQL重启的故障分析全过程~ 现为爱可生高级测试工程师,拥有丰富的自动测试开发经验;曾先后在文思海辉、Splunk担任测试工程师。 一、起因: 在公司测试MySQL高可用组件时发现一个异常。如下: 停止从库,高可用组件将从库自动启[详细]
-
Linux下安装mysql-8.0.21-linux-glibc2.12-x86_64.tar安装过程
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
Linux下安装mysql-8.0.21-linux-glibc2.12-x86_64.tar安装过程: 1、解压mysql mysql-8.0.21-linux-glibc2.12-x86_64.tar 解压 tar -xvf mysql-8.0.21-linux-glibc2.12-x86_64.tar tar -xvJf mysql-8.0.21-linux-glibc2.12-x86_64.tarr.xz 2、cp -r mysql-8.[详细]
-
Mysql数据库二进制日志的管制
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
如果配置了log_bin参数,则需要配置expire_logs_days参数指定二进制日志保留时间,不然磁盘空间早晚会被日志占满的。如果之前没有配置,则配置步骤如下: 1、查看当前配置 (root@localhost)[(none)] show global variables like log_bin; +---------------+-[详细]
-
mysql用具和选项
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
mysql工具和选项: 一、MYSQL服务器和主要配套工具 工具名称 简单介绍 示例 mysqld MYSQL服务程序 mysql 以交互式执行sql命令的工具程序 mysql -uroot -proot mysqld_safe 安全启动MYSQL服务器 mysqld_safe --defaults-file=/u01/3307/my.cnf 21 /dev/null m[详细]
-
MySQL5.7主从复制-GTID复制创建
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
两台服务器,系统是Redhat6.5,MySQL版本是5.7.18。 1、在主库上,创建复制使用的用户,并授予replication slave权限。这里创建用户repl,可以从IP为10.10.10.210的主机进行连接。 grant replication slave on *.* to repl@10.10.10.210 identified by mysql[详细]
-
每隔30秒循环收集 innodb 情况信息的SHELL脚本
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
x=0 while [ $x -lt 10 ] do expect eof spawn mysql -u root -p -e SHOW ENGINE INNODB STATUSG expect *password: send 123456r expect eof EOF x=`expr $x + 1` echo ######################################################################### inn[详细]
-
mysql 锁分析有关命令
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
mysql 锁分析相关命令: 1.服务器级别的锁等待 可以通过show (full) processlist看到等待锁的线程id,但是无法知道究竟哪个线程持有锁 可以通过mysqladmin debug 相关等待锁的线程以及谁持有锁可以在错误日志中找到 2.存储引擎层的锁等待则比较麻烦,以下[详细]
-
mysql数据库 复制 的方法
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
mysqldump wap -u root -ppassword --add-drop-table | mysql test -u root -ppassword 这样就用本地的wap数据库,复制到了test数据库。当然,这里的例子数据库都数本地的。 通过给定选项h,也可以指定一个远程的mysql。 这个例子,在做开发的时候很有用:用[详细]
-
MySQL备份和复原工具
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
之前没有认真整理,感觉备份工具就是mysqldump,xtrabackup了,但是如果认真想一想,其实会发现还是有很多其他丰富的功能。 比如数据的逻辑导出,比如某个表的数据(全部,部分)等都可以很方便的实现,这些比那些备份工具来说要轻巧很多,方便迁移。 把这些[详细]
-
Centos 7.6 下Mysql8.0.16编译安置
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
Centos 7.6 下Mysql8.0.16编译安装 1.最小化安装系统 2.安装基础包 yum -y install ntpdate gcc gcc-c++ ncurses ncurses-devel cmake readline-devel zlib.x86_64 zlib-devel.x86_64 bison libcurl-* net-tool* tree nmap sysstat lrzsz dos2unix telnet.x8[详细]
-
MySQL中insert语句没有响应的问题剖析
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
今天开发的一个同学问我一个MySQL的问题,说在测试数据库中执行一条Insert语句之后很久没有响应。我一看语句是一个很常规的insert into xxx values形式的语句。看起来有些不太合乎常理啊,我对这类问题立马来了兴趣,准备好好看看到底是什么原因。 向开发同[详细]
-
MySQL级联复制的同步难题
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
今天碰到一个有些奇怪的问题,有一套环境,在主从复制的时候有一些问题。 大体的流程设计如下: 三个节点位于三个不同的区域,因为节点1和节点3之间的网络存在问题,所以走了节点2来中转,由此可见延迟是难免的,但是延迟不能太大。最终的数据还是要通过节点[详细]
-
mysql基本 游标
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
mysql基础 游标: 一、游标的定义: create procedure p12() begin declare row_name varchar(20); declare row_num int; declare myCursor cursor for select name,num from goods;//定义游标myCursor open myCursor;//打开游标myCursor fetch myCursor int[详细]
-
MySQL在RR隔离等级下的unique失效和死锁模拟
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
今天在测试MySQL事务隔离级别的时候,发现了一个有趣的问题,也参考了杨一之前总结的一篇。http://blog.itpub.net/22664653/viewspace-1612574/ 问题的背景是在MySQL隔离级别为RR(Repeatable Read)时,唯一性约束没有失效,多并发的场景下能够复现出下面的[详细]
